Download the latest stable xtd.tunit version

You can download latest stable version on SourceForge.

SourceForgeDownload

Clone the latest xtd.tunit commit

Or clone latest development version on GitHub.

Installation

Windows 7 SP1 or later

  • Install Microsoft Visual Studio 2017 Community

    In order to build xtd.tunit, you first need download and install Microsoft Visual Studio 2017 community from https://www.visualstudio.com.

  • Install CMake 3.3 or later

    After Microsoft Visual Studio, you need to install the latest version cmake from https://cmake.org/download/

    Remarks: Verify if you can execute 'cmake --version' in "Command Prompt", if it's no, add cmake install directory to your path.

  • After installing Microsoft Visual Studio and CMake, do the following in "Command Prompt" to build and install xtd.tunit :

cd C:\Users\YourName\xtd.tunit\

install.cmd

  • Create as many unit tests as you want with xtd.tunit.

macOS 10.14 (OS X Mojave) or later

  • Install Xcode 10 or later

    In order to build xtd.tunit, you first need download and install Xcode from App Store and install "Commands line tools".

    Remarks: Verify if you can execute 'clang --version' in "Terminal".

  • Install Homebrew

    After Xcode, to build Switch, you need to install package manager Homebrew (http://brew.sh).

/usr/bin/ruby -e "$(curl -fsSL ttps://raw.githubusercontent.com/Homebrew/install/master/install)"

  • After installing Xcode and Homebrew, do the following in "Terminal" to Build and install :

cd /Users/YourName/YourProject/

./install.sh

  • Create as many unit tests as you want with xtd.tunit.

CentOS 7, Debian 9.7, Elementary OS 5.0, Fedora 29, LinuxMint 19.1, RedHat 7.5 and Ubuntu 18.04 (or later)

  • Do the following in "Terminal" to Build and install :

cd /Users/YourName/YourProject/

./install.sh

  • Create as many unit tests as you want with xtd.tunit.

Other linux Distribution

  • Install g++ 7 or later

    In order to build , you first need download and install g++ 7 or later.

    Remarks: Verify if you can execute 'g++ --version' in "Terminal".

  • Install CMake 3.3 or later

    After Microsoft Visual Studio, you need to install the latest version cmake from https://cmake.org/download/

    Remarks: Verify if you can execute 'cmake --version' in "Terminal", if it's no, add cmake install directory to your path.

  • After installing g++ and CMake, do the following in "Terminal" to Build and install :

cd /Users/YourName/YourProject/

./install.sh

  • Create as many unit tests as you want with xtd.tunit.

© 2019 Gammasoft.

  • Github
  • SourceForge
  • White Facebook Icon
  • White Twitter Icon
This site was designed with the
.com
website builder. Create your website today.
Start Now